miércoles, 14 de mayo de 2008

Error con GPM

Bueno pues ya tenia tiempo que no actualizaba los paquetes en Arch Linux, con el ya conocido comando pacman -Syu , pero ayer mientras intentaba actualizar me salio un error..

error: no se pudo preparar la transacción
error: no se pudo iniciar la operación (archivos en conflicto)
gpm: /usr/lib/libgpm.so.1 existe en el sistema de archivos
Ocurrieron errores, no se actualizaron paquetes


Y pues ya no actualize, pero hoy ya me voy a googlear un poco (o mejor dicho casi nada, primer resultado), y el problema era demasiado simple, ya esta resuelto en las paginas de Arch, solo por flojera a no buscar no me habia dado cuenta XD.

Asi que les dejo la solucion citandola de la fuente de Arch Linux En Español - Comunidad Hispana

Cuando trates de actualizar gpm 1.20.3-1 posiblemente verás el siguiente error:

error: no se pudo preparar la transacción
error: no se pudo iniciar la operación (archivos en conflicto)
gpm: /usr/lib/libgpm.so.1 existe en el sistema de archivos
Ocurrieron errores, no se actualizaron paquetes

esto ocurre porque el enlace /usr/lib/libgpm.so.1 se ha desasociado del paquete (FS#9949). Se ha solucionado en el paquete gpm-1.20.3-1 pero hay que forzar la actualización:

pacman -Syf gpm
pacman -Syu


Update

12 de Octubre del 2008
Ultimamente, tambien pacman me estuvo mandando un error, aunque no supe exactamente con que paquete.
Lo e solucionado con un

pacman -Syf

De esta forma fuerza a pacman a hacer un update.

Fuente: Arch Linux en Español
Original: ArchLinux.org

2 comentarios:

Anónimo dijo...

Gracias!

Después de haber bajado 1.5GB de actualizaciones me quería matar si no actualizaba.

Ahora marcha todo impecable =)

Juan Mancha dijo...

De nada ^^ , es bueno saber que le haya servido a alguien

Ya que a mi me sucedio 2 veces y no sabia porque >.< , hasta que descubri la razon xD =P

Salu2!